Skip to main content

App refuses to install on Samsung Gear Fit2 Pro SM-R365

Comments

14 comments

  • Official comment
    John Anthony

    Hi folks - apologies for the lack of reply on this. We are investigating the issue and will post back once we have a solution.

  • John Anthony

    For those not able to use Tizen Studio, here is an alternate method to try:

     

    To get Watch’s log

    1. Connect watch with Phone using Bluetooth
    2. Run Dialer in Watch
    3. Press *#9900# and “Log dump” app will launch
    4. Select “Run LOG_DUMP” and wait for few minutes until it finishes.
    5. Select “Extract LOG_DUMP” and wait for few minutes until it finishes.
    6. Connect the PHONE with your PC using USB cable
    7. Locate “Pictures” folder in Phone storage and copy “Watch” folder
    8. You will find the logs in zip file.
    1
  • Denis Soares Franco

    I have the same problem.

    0
  • Pablo Abellán

    Yo tengo el mismo problema. Al intentar instalar "Swim.com Advanced Swim Tracking for Gear Fit2 Pro" desde Galaxy Store, Empieza la instalación, y cuando finaliza la transferencia al reloj y empieza la instalación da también el mismo error "no se ha podido instalar la aplicación - Error de instalación. Inténtelo más tarde (WO:WO:9079)

    0
  • MichaelB

    I also have this issue. Very frustrating, as I enjoy the app very much. Strange thing though, I tried it from an Apple device and it installed ok. I think there is something going on with particular Android versions. I have a Note 8. What devices do you have? If there were a way to sideload the app, I would do it. Trying to figure out how to get the apk equivalent file for the app.  I have gotten no response from swim.com support on the issue.

    0
  • Peter B.

    I use a Samsung Galaxy S9+ with Android 10 installed. APK file does not work since the watch has no USB-Port and the only way to install Apps is the Wearable store. I tried it with the developer mode but was not able to transfer an APK file. Would be nice if the swim.com developers could fix that problem.

    0
  • MichaelB

    Well, there goes my "Android version" theory.  I'm on Android 9 and now I know that upgrading my phone is unlikely to fix it.  I wonder if anyone is having this issue with the app on the Galaxy Active 2 or one of the other Samsung wearables.  @Swim.com, please fix this problem.  You have a great app if we could only install it.

    0
  • ג'ק ברוך

    I solve the problem by doing phone downgrade.
    I used the galaxy note 5 and recently I bought Note 20 5G. The application does not work with this android version 11 so I return to the Note 5 and connected my gear fit2 pro with him and now it work perfectly.
    Yes, I know that I can not use it with my new phone but actually I use my Gear S3 for daily use and the Gear fit2 pro is only for the pool. If you used it in daily basis you are still stuck with the problem.

    0
  • Denis Soares Franco

    It appears to be a compatibility issue with Samsumg phones.

    I opened a ticket (january, 29) and was given the following answers:

    "I think that issue might be related to asetting we have enable or disabel in our Samsng developer account that alows or disallows certain phone models form installing the app. I wil reach out to our engenierers to see if they can remedy the issue as soon as possible". (february ,1st)

    "Our developers have reached out to Samsung in order to try to fix the issue and I will let you know once I hear anything back regardin this matter". (february, 3th)

    "Unfortunately I do not have nay update a this time. I am still waiting for information from Samsung and our lead developer about this" (february, 18)

    I thnk it would be convenient for everyone to do the same, opening a ticket (in app: settings\support\tickets) in order to charge and expedite measures to solve the problem.

     

    0
  • John Anthony

    Hi everyone. We are working with Samsung to figure out what the issue is. They have asked us to try and collect a log dump from a few of the devices that are not able to install the Swim.com app. Would any of you be willing to follow the below instructions and then send the ZIP file to support@swim.com with the subject link of "Gear Fit2 Pro Log Dump"?

    Thanks in advance! We hope to get this resolved ASAP.

    Instructions

    1. Open Settings>Gear Info>About Device 
    2 . Scroll down to Serial Number and tap on it five times 
    3. (The number pad appears), enter *#9900# 
    4. Select Run LOG_DUMP 
    5. Connect to the Gear Fit2 via Tizen Studio 
    6. In Tizen Studio file explorer, select the log_dump file in /opt/usr/media/SLP_Debug/ and “pull” the file 
    0
  • Denis Soares Franco

    John, 

    I generated the log dump file, but I can not connect connect the my gear fit2 pro via Tizen. Could you help me with the instructions to do that?

    0
  • Pablo Abellán

    Tengo el mismo problema: He generado el fichero "log_dump" pero no encuentro la aplicación Tizen Studio para poder transferir dicho fichero al móvil y enviarlo

    0
  • Denis Soares Franco

    Tizen connection finally worked! I sent the files by email as recommended. I hope it can help to remedy the problem.

    Thanks John!

    0
  • Pablo Abellán

    Gracias John pero NO he podido realizar el siguiente paso en mi teléfono móvil Samsung Galaxy S8+):

    1. Select “Extract LOG_DUMP” and wait for few minutes until it finished (se queda en 0% y no envía nada del Gear al móvil)

    Al final he optado por la siguiente solución:

    - He instalado la App Galaxy Wearable en un móvil de otro fabricante (Motorola)

    - He vinculado mi Samsung Gear Fit2 Pro al nuevo móvil Motorola

    - He descargado vuestra aplicación SWIM sin problema alguno en mi Samsung Gear Fit2 Pro.

    - He descargado la App SWIM en mi móvil Motorola y vinculado la App del móvil con la de Samsung Gear Fit2 Pro sin problema alguno.

    , así que por fin puedo usarla en mi Gear pero vinculándolo con un móvil motorola.

    Está claro que el problema estaba en la instalación en el Gear desde mi móvil Samsung Galaxy S8+

    Agradecer vuestra atención e interés por intentar resolver esta incidencia.

    Un saludo.

     

    0

Please sign in to leave a comment.

Powered by Zendesk